1

Is the procedure below viable for performing a VIOS update and, at the same time, preparing for a quick back out if necessary?

Assume that the existing VIOS is mirrored on hdisk0 and hdisk1. Therefore, the bootlist would contain entries for both hdisk0 and hdisk1.

Step 1. Perform a mksysb backup just in case any of the following goes awry.

$ backupios -file <path to NFS location>/<file name> -mksysb

Step 2. Break the mirror (this step will remove the contents of hdisk1)

$ unmirrorios hdisk1

Step 3. Remove hdisk1 from the rootvg Volume Group

$ reducevg hdisk1

Step 4. Change the bootlist to only contain hdisk0 with these commands:

$oem_setup_env
# bosboot -ad /dev/hdisk0
# bootlist -m normal hdisk0 blv=hd5

Step 5. Clone the existing VIOS using the alt_root_vg command

$ alt_root_vg -target hdisk1 -bundle update_all -location < path-to-VIOS-update-package >

Step 6. Restart the VIOS to confirm it starts just on hdisk0

$ shutdown –restart

Now VIOS is only booting from hdisk1, but two copies exist (hdisk0 and hdisk1), see documentation for alt_root_vg command

Step 7. Now perform the VIOS update only on hdisk0

$ updateios -accept -install -dev /some-device

Step 8. Now perform testing of the new VIOS installed on hdisk1

Step 9. If no VIOS problems skip to Step 9. If there are problems and the new VIOS needs to be backed out simply change the bootlist to hdisk0 and restart the VIOS

# bosboot -ad /dev/hdisk0
# bootlist -m normal hdisk0 blv=hd5

Step 10. Now restart the VIOS and it should be back on the original VIOS.

Step 11. Re-establish the mirror

$ mirrorios -defer hdisk0

Step 12. Re-establish the correct bootlist for the mirrored disks

# bosboot -ad /dev/hdisk0
# bosboot -ad /dev/hdisk1
# bootlist -m normal hdisk0 hdisk1
Brian G
  • 11
  • I don't know VIOS personally but just want to point out to you that if you don't get any response here you might have some luck on our sister project, serverfault.com. – ojs Dec 12 '20 at 19:05
  • This does not seem like a good candidate for a question, as it basically implies a yes/no answer, which might not be very useful. Also, you're missing some context information e.g. the source/target ioslevel. In general I'd say this looks sound, but the second half of 5. and 7. seem to be redundant. You may also want to compare against some best practices, e.g. "Care and Feeding of VIOS" from Jaqui Lynch or similar current documentation. – doktor5000 Jan 03 '21 at 16:27
  • I agree with @doctor5000 that something posed for a yes/no is not the best question. However, I will say, here, yes, as you are using oem_setup_env as your root prompt, and treating VIOS as merely AIX as you clone, and switch back to the application aka blackbox interface known as VIOS to perform the update. In short, classic AIX update procedure based on disk cloning. The other procedure_ would have been to use NIM and make an mksysb backup, and restore that if there were problems. Then you would not need to have, nor break a mirror. (It reads a bit like something Jaqui would say). – Michael Felt Feb 24 '22 at 20:13

0 Answers0